| qauthenticator.cpp |
|
59907 |
- |
| qauthenticator.h |
|
1300 |
- |
| qauthenticator_p.h |
|
3288 |
- |
| qdnslookup.cpp |
Sorts a list of QDnsMailExchangeRecord objects according to RFC 5321.
|
43374 |
- |
| qdnslookup.h |
|
10926 |
- |
| qdnslookup_dummy.cpp |
|
471 |
- |
| qdnslookup_p.h |
|
8579 |
- |
| qdnslookup_unix.cpp |
|
24657 |
- |
| qdnslookup_win.cpp |
|
10987 |
- |
| qhostaddress.cpp |
|
40053 |
- |
| qhostaddress.h |
|
5181 |
- |
| qhostaddress_p.h |
|
3003 |
- |
| qhostinfo.cpp |
The calling thread is likely the one that executes the lookup via
QHostInfoRunnable. Unless we operate with a queued connection already,
posts the QHostInfo to a dedicated QHostInfoResult object that lives in
the same thread as the user-provided receiver, or (if there is none) in
the thread that made the call to lookupHost. That QHostInfoResult object
then calls the user code in the correct thread.
The 'result' object deletes itself (via deleteLater) when
finalizePostResultsReady is called.
|
36731 |
- |
| qhostinfo.h |
|
3528 |
- |
| qhostinfo_p.h |
|
5982 |
- |
| qhostinfo_unix.cpp |
|
4716 |
- |
| qhostinfo_win.cpp |
|
1040 |
- |
| qnetworkdatagram.cpp |
|
19508 |
- |
| qnetworkdatagram.h |
|
2639 |
- |
| qnetworkdatagram_p.h |
|
1709 |
- |
| qnetworkinformation.cpp |
|
28399 |
- |
| qnetworkinformation.h |
|
2877 |
- |
| qnetworkinformation_p.h |
|
4565 |
- |
| qnetworkinterface.cpp |
!
\class QNetworkAddressEntry
\brief The QNetworkAddressEntry class stores one IP address
supported by a network interface, along with its associated
netmask and broadcast address.
\since 4.2
\reentrant
\ingroup network
\ingroup shared
\inmodule QtNetwork
Each network interface can contain zero or more IP addresses, which
in turn can be associated with a netmask and/or a broadcast
address (depending on support from the operating system).
This class represents one such group.
|
31321 |
- |
| qnetworkinterface.h |
|
4538 |
- |
| qnetworkinterface_linux.cpp |
in case these aren't defined in linux/if_arp.h (added since 2.6.28) |
13694 |
- |
| qnetworkinterface_p.h |
|
3435 |
- |
| qnetworkinterface_uikit_p.h |
Ethernet
|
8336 |
- |
| qnetworkinterface_unix.cpp |
|
20263 |
- |
| qnetworkinterface_unix_p.h |
|
2078 |
- |
| qnetworkinterface_win.cpp |
|
8394 |
- |
| qnetworkproxy.cpp |
!
\class QNetworkProxy
\since 4.1
\brief The QNetworkProxy class provides a network layer proxy.
\reentrant
\ingroup network
\ingroup shared
\inmodule QtNetwork
QNetworkProxy provides the method for configuring network layer
proxy support to the Qt network classes. The currently supported
classes are QAbstractSocket, QTcpSocket, QUdpSocket, QTcpServer
and QNetworkAccessManager. The proxy support is designed to
be as transparent as possible. This means that existing
network-enabled applications that you have written should
automatically support network proxy using the following code.
\snippet code/src_network_kernel_qnetworkproxy.cpp 0
An alternative to setting an application wide proxy is to specify
the proxy for individual sockets using QAbstractSocket::setProxy()
and QTcpServer::setProxy(). In this way, it is possible to disable
the use of a proxy for specific sockets using the following code:
\snippet code/src_network_kernel_qnetworkproxy.cpp 1
Network proxy is not used if the address used in \l
{QAbstractSocket::connectToHost()}{connectToHost()}, \l
{QUdpSocket::bind()}{bind()} or \l
{QTcpServer::listen()}{listen()} is equivalent to
QHostAddress::LocalHost or QHostAddress::LocalHostIPv6.
Each type of proxy support has certain restrictions associated with it.
You should read the \l{ProxyType} documentation carefully before
selecting a proxy type to use.
\note Changes made to currently connected sockets do not take effect.
If you need to change a connected socket, you should reconnect it.
\section1 SOCKS5
The SOCKS5 support since Qt 4 is based on
\l{http://www.rfc-editor.org/rfc/rfc1928.txt}{RFC 1928} and
\l{http://www.rfc-editor.org/rfc/rfc1929.txt}{RFC 1929}.
The supported authentication methods are no authentication and
username/password authentication. Both IPv4 and IPv6 are
supported. Domain names are resolved through the SOCKS5 server if
the QNetworkProxy::HostNameLookupCapability is enabled, otherwise
they are resolved locally and the IP address is sent to the
server. There are several things to remember when using SOCKS5
with QUdpSocket and QTcpServer:
With QUdpSocket, a call to \l {QUdpSocket::bind()}{bind()} may fail
with a timeout error. If a port number other than 0 is passed to
\l {QUdpSocket::bind()}{bind()}, it is not guaranteed that it is the
specified port that will be used.
Use \l{QUdpSocket::localPort()}{localPort()} and
\l{QUdpSocket::localAddress()}{localAddress()} to get the actual
address and port number in use. Because proxied UDP goes through
two UDP connections, it is more likely that packets will be dropped.
With QTcpServer a call to \l{QTcpServer::listen()}{listen()} may
fail with a timeout error. If a port number other than 0 is passed
to \l{QTcpServer::listen()}{listen()}, then it is not guaranteed
that it is the specified port that will be used.
Use \l{QTcpServer::serverPort()}{serverPort()} and
\l{QTcpServer::serverAddress()}{serverAddress()} to get the actual
address and port used to listen for connections. SOCKS5 only supports
one accepted connection per call to \l{QTcpServer::listen()}{listen()},
and each call is likely to result in a different
\l{QTcpServer::serverPort()}{serverPort()} being used.
\sa QAbstractSocket, QTcpServer
|
52488 |
- |
| qnetworkproxy.h |
|
5690 |
- |
| qnetworkproxy_android.cpp |
|
3050 |
- |
| qnetworkproxy_darwin.cpp |
MacOS X has a proxy configuration module in System Preferences (on
MacOS X 10.5, it's in Network, Advanced), where one can set the
proxy settings for:
\list
\li FTP proxy
\li Web Proxy (HTTP)
\li Secure Web Proxy (HTTPS)
\li Streaming Proxy (RTSP)
\li SOCKS Proxy
\li Gopher Proxy
\li URL for Automatic Proxy Configuration (PAC scripts)
\li Bypass list (by default: *.local, 169.254/16)
\endlist
The matching configuration can be obtained by calling CFNetworkCopySystemProxySettings()
(from <CFNetwork/CFProxySupport.h>). See
Apple's documentation:
https://developer.apple.com/documentation/cfnetwork/1426754-cfnetworkcopysystemproxysettings?language=objc
|
14192 |
- |
| qnetworkproxy_generic.cpp |
Construct a proxy from the environment variables http_proxy and no_proxy.
Or no system proxy. Just return a list with NoProxy.
|
3782 |
- |
| qnetworkproxy_libproxy.cpp |
Gets the list of proxies from libproxy, converted to QUrl list. Apply
thread-safety, though its documentation says otherwise, libproxy isn't
thread-safe.
|
6753 |
- |
| qnetworkproxy_win.cpp |
|
21126 |
- |
| qtcontenttypeparser_p.h |
|
7573 |
- |
| qtldurl.cpp |
|
6462 |
- |
| qtldurl_p.h |
|
834 |
- |
| qtnetworkglobal.h |
|
368 |
- |
| qtnetworkglobal_p.h |
|
856 |
- |